Open Iron from command line in new tab of existing window

Iron Forum for english speaking people
jamvaru
Posts: 2
Joined: Fri Mar 01, 2019 12:00 pm

Open Iron from command line in new tab of existing window

Postby jamvaru » Fri Mar 01, 2019 12:17 pm

Can you help me with a simple batch command? I'm trying to open a web page in Iron Browser from a batch file set on a timer in windows task scheduler.

Something like this:

START G:\pApps\PortableApps\IronPortable\IronPortable.exe "https://mixer.com/PaladinsGame"

but when i try it it says Iron is already running, and to close it and then try again.

So, I figured there is probably a command-line option to open the page in a new tab instead of a new window or new process.

I'm using the pApps version on a hard drive instead of the ssd because it uses that hard drive for the video cache instead of the ssd. Even if I use the pApps version of Chrome (google) it will still use the C: drive ssd for the cache instead of the hard drive it is installed on. Thankfully Iron is configured correctly to use the drive it is installed on.

Another possibility is maybe it is the pApps version of Iron that is wonky? I noticed the same behavior in another program, though I've since forgotten which, but it was a pApps program, and it had the same dialog window popup.

Perhaps using the regular version of Iron on that hard drive might work, but I will have to give it a try next.

Thanks for whatever you can suggest. I'd like to figure out how to make the pApps version work.


jamvaru
Posts: 2
Joined: Fri Mar 01, 2019 12:00 pm

Re: Open Iron from command line in new tab of existing window

Postby jamvaru » Sat Apr 06, 2019 4:31 pm

what a curious reply

i downloaded the official version of Iron Portable and it works just fine with the batch command, opening into a new tab

it also has no problem opening if another version of Iron is already running, unlike the pApps version

and it uses the cache on the drive it resides on, rather than the c: drive (unless it is on that drive)

so, problem solved, lol (except for the question of the pApps version not working the same)



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: No registered users and 9 guests