vhosts GUI not working

Posts: 2
Joined: Sun Oct 05, 2014 12:58 pm

vhosts GUI not working

Postby Bilal » Sun Oct 05, 2014 1:03 pm


I'm trying to setup a vhost, it seems the configuration is not send from GUI to httpd-vhosts.conf file. it always write the same default values:

<VirtualHost *:80>
ServerAdmin webmaster@dummy-host.example.com
DocumentRoot "c:/Apache2/docs/dummy-host.example.com"
ServerName dummy-host.example.com
ServerAlias www.dummy-host.example.com
ErrorLog "logs/dummy-host.example.com-error.log"
CustomLog "logs/dummy-host.example.com-access.log" common

<VirtualHost *:80>
ServerAdmin webmaster@dummy-host2.example.com
DocumentRoot "c:/Apache2/docs/dummy-host2.example.com"
ServerName dummy-host2.example.com
ErrorLog "logs/dummy-host2.example.com-error.log"
CustomLog "logs/dummy-host2.example.com-access.log" common

System info:
Portable version
Windows 8.1

User avatar
Site Admin
Posts: 2733
Joined: Sat Jan 19, 2008 4:16 am

Re: vhosts GUI not working

Postby SRWare » Sun Oct 05, 2014 1:25 pm

Vhosts are written to Apache2\conf\securewamp\vhosts.conf
When you edit them, you have to click "Save" bevor exiting
Iron-Updates via Twitter: http://twitter.com/srware

Donations via Paypal and Bitcoin:

100% anonymous VPN with no-log policy:

Posts: 2
Joined: Sun Oct 05, 2014 12:58 pm

Re: vhosts GUI not working

Postby Bilal » Sun Oct 05, 2014 2:27 pm

Thank you for quick reply.

I've tried to clone a website from one live server to securewamp, when I tried to start it locally the page shows an error message:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at admin@example.com to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
The error log file show this error line:
[Sun Oct 05 15:04:05.036076 2014] [core:alert] [pid 8352:tid 3020] [client] R:/SecureWAMP_Portable/htdocs/****(edit by me)/.htaccess: DirectoryIndex not allowed here, referer: http://*****(edit by me)/

After some attempts with vhost.conf, I could solve the problem by changing (AllowOverride AuthConfig FileInfo) to (AllowOverride All).

Thank you for you help.

Return to “Apache”

Who is online

Users browsing this forum: No registered users and 1 guest