Page 1 of 1

Odd 'back button' behaviour.

Posted: Thu Nov 26, 2009 5:35 pm
by DaveIron
Yesterday I enabled the adblocker in Iron & it appears to be working superbly. However I have noticed a strange behaviour in the IMDb site. I find that if I click on a link, one of the 'Born Today' links for example, I find that it is difficult to return to the original page with the back button. Has anyone else noticed anything like this? So far I have not noticed it on any other sites. Could it be an adblocker bug?

Re: Odd 'back button' behaviour.

Posted: Thu Nov 26, 2009 7:46 pm
by DaveIron
I am starting to notice this behaviour on other sites. I did not notice this before I started to use the adblocker. Has anyone else had this problem?

Re: Odd 'back button' behaviour.

Posted: Thu Nov 26, 2009 8:54 pm
by Vibov
I think it happens on websites which redirect the user to a different address.

You make a step back all right... but it redirects you again, and so you're kind of trapped.

You can try pressing and holding down [backspace] on the keyboard - this can override this annoying behaviour, simply because the website can't keep up with you - you're effectively sending the "go back" command over and over more quickly than the website is able to initiate the redirection.

As a result, you finally "jump over" the redirection.

Re: Odd 'back button' behaviour.

Posted: Thu Nov 26, 2009 9:41 pm
by DaveIron
Yes backspace can work. It's a bit hit & miss though & often ends up with a new tab. I think the only reliable way is to right-click on the back button & select from the drop-down menu. It doesn't happen on all sites & I don't remember this activity before I enabled the adblocker. It's nice to be able to look at IMDb without all of those annoying adverts but this is an odd phenomenon. I don't know if they're related. I suppose it's a small price to pay to not to have to look at all of those advert flashplayers. My guess is that it's a bug.

Re: Odd 'back button' behaviour.

Posted: Fri Nov 27, 2009 4:59 pm
by DaveIron
I have also discovered that double-clicking the back button (sometimes more than once) can take you back a page. It seems to be predominantly on links on this page (IMDb). At least I have noticed it here more. I am sure that some links acted normally at first then later I found it difficult to go back a page. Does anyone else have this problem at the IMDb page?

Re: Odd 'back button' behaviour.

Posted: Thu Feb 18, 2010 2:29 pm
by DaveIron
Although Iron #4.0.280 seems to have cured this problem as far as I can tell, I have noticed that on some Yahoo! News links (particularly from my 'My Yahoo!' page) I have to press 'back' twice to return to the original page. This is nowhere near what it was like before though. It seems like a very minor gremlin. ;)

Re: Odd 'back button' behaviour.

Posted: Mon Aug 16, 2010 1:33 am
by JackNapier
I have this problem with the latest linux release (5.0.381). Primarily on a forum that uses vBulletin, if that helps.

Re: Odd 'back button' behaviour.

Posted: Wed Aug 18, 2010 1:23 pm
by DaveIron
JackNapier wrote:I have this problem with the latest linux release (5.0.381). Primarily on a forum that uses vBulletin, if that helps.


OK, thanks for the info. It tends to happen in (Windows) Yahoo! links my 'My Yahoo!' page which is quite customised (5.0.381).

Re: Odd 'back button' behaviour.

Posted: Mon Aug 23, 2010 2:11 am
by DaveIron
It seems that 5.0.382 has fixed this! Excellent. :D :ironvssafari :ironvsff :ironvsopera