NetFlix is 'problematic' in newest versions of Iron...

Iron Forum for english speaking people

Mike_Walsh
Posts: 17
Joined: Tue Nov 29, 2016 12:57 pm

NetFlix is 'problematic' in newest versions of Iron...

Postby Mike_Walsh » Tue Apr 09, 2019 4:43 pm

Afternoon, all.

Up until Iron 69, getting NetFlix to run under Iron in Linux was easy. The WideVine modules just sat inside the main browser directory, and the browser picked them up from there. The Puppy Linux packages I build from the tarball for the 'Puppy' community (both architectures) were super easy to get running properly.

From v70 onwards, things have taken a downhill turn. I suspect internal coding changes over at the Chromium Projects, but of course, I can't prove it.

Trying to build the packages in the same way as previously now results in NetFlix complaining about 'missing components', and insisting I go to 'chrome://components' and 'update' WideVine from there. Only when you do go to 'chrome://components', there's no sign of it.....and nothing I can do will persuade it to appear..! I've even taken onboard a suggestion from a Google Product Forum thread, and duplicated the WideVine modules in /.local/lib within the user's 'home' directory..... Still no joy.

I don't know whether Chromium is now using the same 'proprietary' coding as Chrome, but if they are, then it rather looks like they've 'dropped the ball' and forgotten to pass that information along to developers.

Does anybody have any ideas on this one? Has anybody managed to get NetFlix to behave itself from Iron 70 onwards? Any suggestions would be very much appreciated.


Mike. :wink:


Mike_Walsh
Posts: 17
Joined: Tue Nov 29, 2016 12:57 pm

Re: NetFlix is 'problematic' in newest versions of Iron...

Postby Mike_Walsh » Thu Jun 06, 2019 4:59 pm

*** BUMP ***


kadu
Posts: 2
Joined: Thu Sep 26, 2019 10:44 am

Re: NetFlix is 'problematic' in newest versions of Iron...

Postby kadu » Thu Sep 26, 2019 10:47 am

same issue here

Neflix is not working even when i copy mentioned file from Google-Chrome Version 77.0.3865.90 (Official Build) (64-bit)
cp -p /opt/google/chrome/libwidevinecdm.so /usr/share/iron

anyone with same experience on Linux?


ddv
Posts: 4
Joined: Wed Dec 20, 2017 12:48 am

Re: NetFlix is 'problematic' in newest versions of Iron...

Postby ddv » Thu Dec 05, 2019 8:08 pm

Hi

I have the same problem with libwidevinecdm.so I have tried copying it to my Iron folder (/usr/share/iron), and I cannot get it to work. It will not show in chrome://components/ I have tried with both a version copied from a Chrome install and the one from Slack. Is there something I should do to make Iron register the libwidevinecdm.so?

Hope some one can help with this
Ps I am Linux Mint if that helps with problem solution?


Mike_Walsh
Posts: 17
Joined: Tue Nov 29, 2016 12:57 pm

Re: NetFlix is 'problematic' in newest versions of Iron...

Postby Mike_Walsh » Thu Jan 02, 2020 7:02 pm

@ddv:-

The sad fact of the matter is that the Iron team don't give a rat's ass about this issue because it's of no consequence to them. Simple as that.

For a lot of people, however, this is enough of a deal-breaker that SRWare will find take-up of the browser slowing down eventually, if they can't be bothered to come up with some positive suggestions.....

(And the stupid thing is that it worked perfectly up to and including Iron 69. It's only from 70 onwards that the issue has reared its head.....) I believe the Iron team have removed the Encrypted Media Extension, which is needed for the WideVine stuff to be able to do its thing, but, of course, once again I can't prove it.


Mike. ;)



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: No registered users and 12 guests