Netflix error

Iron Forum for english speaking people
Posts: 1
Joined: Fri Aug 25, 2017 6:40 am

Netflix error

Postby kaisar123 » Fri Aug 25, 2017 6:56 am

Netflix is giving me this error M7121-1331-P7 every time I play something and it wont let me watch any shows because of it. I went on google chrome and everything was fine but when I went back on iron it was broken. tried disabling all my extensions but it did nothing. cleared my cookies and cache but nothing. if you could tell me how to fix this that would be awesome.

Posts: 1
Joined: Wed Sep 06, 2017 6:23 pm

Re: Netflix error

Postby chakalaka91 » Wed Sep 06, 2017 6:27 pm

I have quite the same problem. Since the update to version 60 I can't use Netflix anymore. I also deactivated all of my extansions, but it wouldn't help. I retried installing it, which - you guess - won't help either.

Posts: 18
Joined: Fri May 25, 2012 4:53 am

Re: Netflix error

Postby Ozzy666 » Fri Sep 22, 2017 8:31 am

try iron 59 ... n64_59.exe or if your on 32 bit windows try ... ron_59.exe and then go into the about:components Section of Iron and update everything you see in there

Posts: 2
Joined: Wed Oct 11, 2017 12:27 am

Re: Netflix error

Postby anshackles » Wed Oct 11, 2017 12:31 am

Just so say I too have this issue - and get the same error code from Netflix.

I will hope that this issue gets fixed beyond "use an out of date version" :)

Posts: 2
Joined: Wed Oct 11, 2017 12:27 am

Re: Netflix error

Postby anshackles » Wed Oct 11, 2017 12:41 am

Tried installing version 59 but get the same problem and error code. Win 10 pro x64, using 64bit version of Iron

Posts: 6
Joined: Fri Jun 21, 2013 9:47 pm

Re: Netflix error

Postby TheArkive » Sun Oct 29, 2017 5:48 pm

Hopefully I can help provide some more diagnostic info on this problem. I am on Win 10 x64 but running 32-bit Iron v61.

I was able to do a fresh install on another computer (fresh windows install) with Iron v61 and Netflix works just fine. Of course, no one wants to reformat their entire harddrive just to make a browser work.

My issues started after trying chromium. It seems chromium uses exactly the same profile data as SRWare Iron, and conflicting versions of chromium/Iron will cause profile corruption.

Unfortunately, I have already tried a reinstall with:
- deleting AppData/Local/Chromium
- searching for "srware" in the registry and deleting all results

... but this does not fix the issue. There seems to be some kind of issue with a "complete uninstall". Netflix troubleshooting pages only reference "using a compatible browser" and "uninstall / reinstall chrome". So none of Netflix's solutions are intuitive or detailed at all.

On the following chrome page - chrome://media-internals/
... I am able to get a bit of diagnostic data after loading a netflix video (and getting the error mentioned in the OP of this thread). I attached the diagnostic data in the zip file. The data appears to be in json format. This url shows 2 blob entries and lots of diagnostic data when trying to play a video on Netflix and then getting the OP error. The TL;DR of the diag data:

Regarding the FFmpegAudioDecoder codec, there appears to be a WEBMEDIAPLAYER_DESTROYED event.

pipeline_state = kStopped.

the h264 codec is also mentioned in the diag data.

I'm afraid I don't know enough to fully understand the diag data, hopefully the dev can see what's going on.

I just want to say once more that it seems to be a "complete uninstall" issue, so that a subsequent reinstall can fix everything. Also, I first experienced these issues after trying to run Chromium (do NOT run Chromium and SRWare Iron side by side!!). Hope this helps.

I will try running an earlier version of Iron and post my results in an EDIT to this post.

EDIT: Iron v59 (32-bit) is working! I deleted the Appdata/Local/Chormium folder (Win 10), installed, then updated everything in chrome://components. So far so good, trying v61 again.

EDIT2: RECONFIRMED: Iron v61 (and v60?) is affected when trying to play netflix video. Not sure what the deal is. Iron v59 works for me as long as I do a fresh program install (no need to format HDD :D) Once again I was able to get v59 32-bit to work for me just fine. Diag data from chrome://media-internals shows "audio_dds=true", but in the error data attached, "audio_dds=false". Maybe the audio stream can't be pulled / loaded for some reason in v61? I attached the diag data from v59 showing a successful load of netflix video. Hopefully the 2 reports will help!!!
You do not have the required permissions to view the files attached to this post.

Posts: 45
Joined: Wed Nov 14, 2012 10:19 pm

Re: Netflix error

Postby markaz » Thu Jan 04, 2018 8:59 am

This is still a problem in 2018 and srware is doing nothing to take care of it. Pathetic. Shame on you

Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: Google Adsense [Bot] and 13 guests