Page 1 of 2

New Iron-Version: 5.0.381 Stable for MacOS

Posted: Sun Jun 27, 2010 11:26 pm
by SRWare
We can now offer you a stable version of Iron for MacOS X.
You can also use the adblocker and the user agent switcher on Mac now, which is already known from the windows-version.

The changelog in detail:
- integrated Adblocker
- integrated Useragent
- improved speed
- integrated translation function
- optinal extension support in incognito mode
- extended privacy settings (JavaScript Block and much more)
- improved HTML5 Support
- improved bookmark manager
and much more

To activate the adblocker, you have to put the adblock.ini (the same as in the windows version) to the /opt/ directory.
The UA.ini for the user agent switcher has to be also in /opt.

Download:
http://www.srware.net/downloads/iron-mac.zip

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Tue Jun 29, 2010 11:42 pm
by nihalz
awesome release!!!

but i cannot make the adblocker work...i cannot find the opt directory anywhere
can anyone please tell me where the opt directory is located? or do i have to create it?

thanks

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jun 30, 2010 9:13 am
by SRWare
nihalz wrote:awesome release!!!

but i cannot make the adblocker work...i cannot find the opt directory anywhere
can anyone please tell me where the opt directory is located? or do i have to create it?

thanks


http://ecmarchitect.com/archives/2009/10/26/1072

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jun 30, 2010 9:30 am
by SvenH
Works great, thanks.

Question: where else can I put adblock.ini and/or how do I point Iron to a specific adblock.ini? I am already using command line switches to the Chromium executable. I do not have root/admin access to my Mac hence no access to /opt.

Sven

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jun 30, 2010 9:49 am
by SRWare
SvenH wrote:Works great, thanks.

Question: where else can I put adblock.ini and/or how do I point Iron to a specific adblock.ini? I am already using command line switches to the Chromium executable. I do not have root/admin access to my Mac hence no access to /opt.

Sven


Sorry, at the moment it can be only put in /opt/.

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Fri Jul 02, 2010 11:36 pm
by dajinni
Very nice!

Vielen dank !

:ironvsff

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jul 07, 2010 4:07 pm
by davidwootton
I've just installed the Mac version, and tried to follow the instructions for installing adblocker. If I enter into terminal the command sudo SetFile -a v /opt the response I get is "command not known". Am I entering the wrong command? Or in the wrong place? I'm running Mac OS X 10.6.4. A very simple set of instructions for a relatively unskilled person would be a great help -- I'm keen to adopt this programme, but only if I can run adblocker with it!

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jul 07, 2010 5:29 pm
by SRWare
davidwootton wrote:I've just installed the Mac version, and tried to follow the instructions for installing adblocker. If I enter into terminal the command sudo SetFile -a v /opt the response I get is "command not known". Am I entering the wrong command? Or in the wrong place? I'm running Mac OS X 10.6.4. A very simple set of instructions for a relatively unskilled person would be a great help -- I'm keen to adopt this programme, but only if I can run adblocker with it!


Try it this way:
-Open command line
-Type: sudo nano /opt/adblock.ini
-Paste the content of http://www.srware.net/downloads/adblock.ini in the editor and save the file
-Restart iron

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Wed Jul 07, 2010 8:09 pm
by davidwootton
Thanks for this help, but I had already found what seems like an even easier solution. This is an add-on for chrome which seems to function fine in iron:
http://download.cnet.com/Adblock-for-Ch ... 00931.html
If I am right you should be encouraging everyone to install it -- or are there people who really want ads???

Re: New Iron-Version: 5.0.381 Stable for MacOS

Posted: Sat Jul 10, 2010 7:44 pm
by rsmereka
Thanks But,

No indication of what versions of Mac OS X are supported. I am running 10.4 (Tiger) and when I attempt to run the application, I get a dialog saying this version of Mac OS is not supported.

What's the scoop?

Rick