Page 1 of 2

New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Thu Dec 15, 2016 11:55 am
by SRWare
We released the new Iron for Linux 55 today, which contains all features and updates known from Chromium 55. The current version is 55.2900.0.

Main improvements:
- HTML5 as default
- huge memory saving improvements
- performance improvements
- Bug-/Securityfixes

On Debian and distributions which use an older Kernel the following commands may be necessary (the .deb packages already do it automatically):

Code: Select all

cd [insert Iron directory here]
sudo chown root chrome-sandbox
sudo chmod 4755 chrome-sandbox
sudo chmod 4755 chrome-wrapper
./chrome-wrapper (for the start of Iron)


On Kubuntu, Lubuntu and other Non-GNOME-Distributions, please run once:

Code: Select all

apt-get install libgconf-2-4


To enable Netflix oder Amazon Video you have copy libwidevinecdm.so from an original Google Chrome installation to the Iron folder.
Alternative: Get it from the Slackware-Respos: http://www.slackware.com/~alien/slackbu ... ne-plugin/

How to get Flash working:
viewtopic.php?f=18&t=8295

You can launch the "Config and Backup Tool" via ./IronConfigBackup or via the Shell as "SRWare Iron Config and Backup Tool" under Networks


Downloads:
http://www.srware.net/downloads/iron-linux.tar.gz (32-Bit)
http://www.srware.net/downloads/iron-linux-64.tar.gz (64-Bit)

Downloads for Debian-based distributions (Debian, Ubuntu, Mint etc.):
http://www.srware.net/downloads/iron.deb (32-Bit)
http://www.srware.net/downloads/iron64.deb (64-Bit)

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Thu Dec 15, 2016 5:38 pm
by johnw615
First of all, thank you for supporting the Linux community with Iron.

I noticed a change with this version.

The binary has changed from /usr/share/iron/iron to /usr/share/iron/chrome

Because of this, either (1) the entries in the menus need to be changed to get this version of Iron to launch, or (2) the binary in /usr/share/iron/chrome needs to be renamed to /usr/share/iron/iron

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Thu Dec 15, 2016 9:20 pm
by SRWare
johnw615 wrote:First of all, thank you for supporting the Linux community with Iron.

I noticed a change with this version.

The binary has changed from /usr/share/iron/iron to /usr/share/iron/chrome

Because of this, either (1) the entries in the menus need to be changed to get this version of Iron to launch, or (2) the binary in /usr/share/iron/chrome needs to be renamed to /usr/share/iron/iron


Should be done normally by itself when using the .deb

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Sat Dec 17, 2016 12:27 pm
by SRWare
On Kubuntu, Lubuntu and other Non-GNOME-Distributions, please run once:

Code: Select all

apt-get install libgconf-2-4

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Sun Dec 18, 2016 5:28 pm
by victor
SRWare wrote:On Kubuntu, Lubuntu and other Non-GNOME-Distributions, please run once:

Code: Select all

apt-get install libgconf-2-4


is there any how to for non ubuntu or debian derivatives?

i want to "install" it on solus and as i were using another distros before. i thought i had saved a site with and all around install instructions for tar.gz packages but im unable to find it.

can you tell me?

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Sun Dec 18, 2016 6:04 pm
by SRWare
victor wrote:
SRWare wrote:On Kubuntu, Lubuntu and other Non-GNOME-Distributions, please run once:

Code: Select all

apt-get install libgconf-2-4


is there any how to for non ubuntu or debian derivatives?

i want to "install" it on solus and as i were using another distros before. i thought i had saved a site with and all around install instructions for tar.gz packages but im unable to find it.

can you tell me?


Launch with ./chrome-wrapper

There is also a README.txt inside

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Mon Dec 19, 2016 12:49 am
by xtonda
On Ubuntu Server 16.04 32 bit with XFCE4 installed I am getting this error

$ /usr/share/iron/chrome
bash: /usr/share/iron/chrome: cannot execute binary file: Exec format error

and file shows this
$ file /usr/share/iron/chrome
/usr/share/iron/chrome: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.26, BuildID[sha1]=0aa28bd9fe4695fbde286fe239729b31646f4534, not stripped

looks like 32 bit packege cointains 64 bit binaries

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Mon Dec 19, 2016 2:54 am
by SRWare
xtonda wrote:On Ubuntu Server 16.04 32 bit with XFCE4 installed I am getting this error

$ /usr/share/iron/chrome
bash: /usr/share/iron/chrome: cannot execute binary file: Exec format error

and file shows this
$ file /usr/share/iron/chrome
/usr/share/iron/chrome: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.26, BuildID[sha1]=0aa28bd9fe4695fbde286fe239729b31646f4534, not stripped

looks like 32 bit packege cointains 64 bit binaries


You are right, thank you. We repackaged the .deb and uploaded it again.

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Mon Dec 19, 2016 8:48 pm
by johnw615
SRWare wrote:
johnw615 wrote:First of all, thank you for supporting the Linux community with Iron.

I noticed a change with this version.

The binary has changed from /usr/share/iron/iron to /usr/share/iron/chrome

Because of this, either (1) the entries in the menus need to be changed to get this version of Iron to launch, or (2) the binary in /usr/share/iron/chrome needs to be renamed to /usr/share/iron/iron


Should be done normally by itself when using the .deb


I always install using the 64-bit deb. Just downloaded and installed on my main system and there was no renaming. I had to manually change the name /usr/share/iron/chrome to /usr/share/iron/iron to get srware iron to launch when clicking on the desktop icon.

Re: New Iron-Version: 55.0.2900.0 Stable for Linux

Posted: Thu Dec 22, 2016 2:20 am
by branwerks
Can we please get a .rpm package to install ? I noticed in earlier versions .rpm was listed as beta but not with this release. Using Alien to convert .deb to .rpm worked but Iron can't build with yumex in Fedora 25 using a .rpm that was converted from .deb (this is never a guarantee in any case and so is unreliable). I get a libav.so.50 error and that's as far as I can get.