New Iron-Version: 54.0.2850.0 Stable for Linux

Iron Forum for english speaking people
User avatar
SRWare
Site Admin
Posts: 2443
Joined: Sat Jan 19, 2008 4:16 am

New Iron-Version: 54.0.2850.0 Stable for Linux

Postby SRWare » Thu Nov 17, 2016 11:32 am

We released the new Iron for Linux 54 today, which contains all features and updates known from Chromium 54. The current version is 54.2850.0.

Main improvements:
- HTTPS-Error fix on some sites
- performance improvements
- Bug-/Securityfixes

On Debian and distributions which use an older Kernel the following commands may be necessary (the .deb packages already do it automatically):

Code: Select all

cd [insert Iron directory here]
sudo chown root chrome-sandbox
sudo chmod 4755 chrome-sandbox
sudo chmod 4755 chrome-wrapper
./chrome-wrapper (for the start of Iron)


To enable Netflix oder Amazon Video you have copy libwidevinecdm.so from an original Google Chrome installation to the Iron folder.

How to get Flash working:
viewtopic.php?f=18&t=8295

You can launch the "Config and Backup Tool" via ./IronConfigBackup or via the Shell as "SRWare Iron Config and Backup Tool" under Networks


Downloads:
http://www.srware.net/downloads/iron-linux.tar.gz (32-Bit)
http://www.srware.net/downloads/iron-linux-64.tar.gz (64-Bit)

Downloads for Debian-based distributions (Debian, Ubuntu, Mint etc.):
http://www.srware.net/downloads/iron.deb (32-Bit)
http://www.srware.net/downloads/iron64.deb (64-Bit)
Iron-Updates via Twitter: http://twitter.com/srware

Donations via Paypal and Bitcoin:
http://iron-start.com/spenden.php


johnw615
Posts: 20
Joined: Thu Mar 15, 2012 5:26 pm

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby johnw615 » Thu Nov 17, 2016 10:53 pm

This version corrected the rendering problems I was having with SRware Iron 53. Thanks for supporting the Linux community. Your browser is #1. :D
Linux Mint 18.1 "Serena" x64 MATE


pacman401
Posts: 12
Joined: Thu Oct 11, 2012 6:48 am

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby pacman401 » Sat Nov 19, 2016 9:00 am

some one forget to warn that launching iron witch switch --process-per-tab causes unable to login every where manually typing or from autofill


rufus_spb
Posts: 9
Joined: Tue Aug 23, 2016 3:04 pm

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby rufus_spb » Sat Nov 19, 2016 11:48 am

Hello

Unfortunately I had to return to previous version (53-rd) because:

1. In "maps.google.com" ALL text I see is painted out. I have attached screenshots from two versions
2. 54-th version uses CPU much more then 53-rd WHEN in plays movie via flash player. I use it on laptop and this is critical
3. Giff animation is still irremovable.

Actually both of this problem is critical to me.
Will use 53-rd version.

Thank you,
All the best
Iron_54_0_2850.jpg

Iron_53_0_2800.jpg



Also a lot of errors about rendering GL:

Code: Select all

[6498:6498:1119/105421:ERROR:buffer_manager.cc(443)] [.DisplayCompositor-0x282909185a00]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
[6498:6498:1119/105421:ERROR:gles2_cmd_decoder.cc(2352)] [.CompositorWorker-0x28290965b100]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
[6498:6498:1119/105421:ERROR:texture_manager.cc(2974)] [.RenderCompositor-0x117ac90c3500]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
[6498:6498:1119/105421:ERROR:gles2_cmd_decoder.cc(2352)] [.RenderWorker-0x117ac90c4300]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
[6498:6498:1119/105451:ERROR:texture_manager.cc(2974)] [.RenderCompositor-0x117ac90c3500]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
[6498:6498:1119/105451:ERROR:gles2_cmd_decoder.cc(2352)] [.RenderWorker-0x117ac90c4300]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
[6498:6498:1119/105453:ERROR:texture_manager.cc(2974)] [.RenderCompositor-0x117ac90c4500]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
[6498:6498:1119/105453:ERROR:gles2_cmd_decoder.cc(2352)] [.RenderWorker-0x117ac90c5300]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
[6498:6498:1119/105502:ERROR:gles2_cmd_decoder_autogen.h(2037)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_ENUM : GetIntegerv: <- error from previous GL command
[6498:6498:1119/105502:ERROR:texture_manager.cc(2974)] [.RenderCompositor-0x117ac90c3500]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
[6498:6498:1119/105502:ERROR:gles2_cmd_decoder.cc(2352)] [.RenderWorker-0x117ac90c4300]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
[6498:6498:1119/105503:ERROR:texture_manager.cc(2181)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_ENUM : glTexImage2D: format was GL_DEPTH_STENCIL_OES
[6498:6498:1119/105503:ERROR:texture_manager.cc(2993)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_VALUE : glTexImage2D:
[6498:6498:1119/105503:ERROR:texture_manager.cc(2993)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_VALUE : glTexImage2D:
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
[6498:6498:1119/105504:ERROR:texture_manager.cc(2535)] [.Offscreen-For-WebGL-0x117ac90c2700]GL ERROR :GL_INVALID_OPERATION : glTexSubImage2D: level 0 does not exist
...

[6498:6498:1119/105504:ERROR:gles2_cmd_decoder.cc(8803)] [.Offscreen-For-WebGL-0x117ac90c2700]RENDER WARNING: texture bound to texture unit 5 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
[6498:6498:1119/105504:ERROR:gles2_cmd_decoder.cc(8803)] [.Offscreen-For-WebGL-0x117ac90c2700]RENDER WARNING: texture bound to texture unit 5 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
[6498:6498:1119/105504:ERROR:gles2_cmd_decoder.cc(8803)] [.Offscreen-For-WebGL-0x117ac90c2700]RENDER WARNING: texture bound to texture unit 4 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
[6498:6498:1119/105504:ERROR:gles2_cmd_decoder.cc(8803)] [.Offscreen-For-WebGL-0x117ac90c2700]RENDER WARNING: texture bound to texture unit 4 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
[6498:6498:1119/105504:ERROR:gles2_cmd_decoder.cc(8803)] [.Offscreen-For-WebGL-0x117ac90c2700]RENDER WARNING: texture bound to texture unit 4 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
You do not have the required permissions to view the files attached to this post.


rufus_spb
Posts: 9
Joined: Tue Aug 23, 2016 3:04 pm

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby rufus_spb » Sat Nov 19, 2016 12:59 pm

Forgot to describe my system:

Linux Xubuntu 14.04 LTS
Linux xub-14-04 3.13.0-101-generic #148-Ubuntu SMP Thu Oct 20 22:08:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Mike_Walsh
Posts: 10
Joined: Tue Nov 29, 2016 12:57 pm

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby Mike_Walsh » Tue Nov 29, 2016 3:05 pm

Afternoon, one and all.

This is my first post here, although I suspect it won't be the last.

I'm a long-term Chrome user; ever since it was in beta back in 2008, in fact. I fell in love with its speed and simplicity.....although it, like so many other browsers, has turned into a lumbering 'super-tanker' due to all the additional security features that have needed to be added over the years.

Originally an XP user, for the last couple of years I've been happily running 'Puppy' Linux, and currently multi-boot around a dozen of the little darlings. Puppy has, until fairly recently, been 32-bit only, mainly because it targets elderly hardware; 64-bit 'Pups' are a fairly recent addition. I re-package the 64-bit versions of Chrome into the SFS 'load-on-the-fly' package format that Pup uses.

Since Google dropped support for 32-bit Chrome, we've been experimenting, on the Puppy Forum, with various other Chromium-based alternatives. We've developed a liking for FlashPeak's Slimjet browser.....but it has one major flaw.....it doesn't support NetFlix. (FlashPeak don't integrate the necessary h264 support into Slimjet.....for 'copyright' reasons!) Iron, however, does. It also has a somewhat different interface, despite being a Chrome 'clone'; the tabs are reminiscent of pre-Australis FireFox! (Ugh!!)

I run two elderly machines; a 12-yr old Compaq desktop PC (pre-HP buyout, so of amazing build quality, and still going strong).....and a 14-yr old Dell Inspiron 1100 laptop.

I wanted to say 'Thanks!' for the current version of Iron. It is finally enabling me to run a bang-up-to-date Chromium 'clone', even on older Puppies with very much older versions of the glibc....all on very elderly hardware. Current versions of Chromium will no longer run on older 'Pups', as it's been compiled against a much more recent version of the 'C' library.

We're using the .deb package, extracting, correcting the permissions for Pup's unique method of operation (it runs as root!!), then re-packaging into the SFS package format. And it runs perfectly.

Cheers! Much appreciated.


Mike. ;)


User avatar
SRWare
Site Admin
Posts: 2443
Joined: Sat Jan 19, 2008 4:16 am

Re: Errors during install Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby SRWare » Sun Dec 04, 2016 11:58 pm

stevedonato wrote:no file called iron exists, and main gnome menu not updated?
deb install displayed this;


You should be able to find it in the "Internet" Section.
If you have no luck after all, then launch "./chrome-wrapper".

If you get any error, please run:
cd [insert Iron directory here]
sudo chown root chrome-sandbox
sudo chmod 4755 chrome-sandbox
sudo chmod 4755 chrome-wrapper
./chrome-wrapper (for the start of Iron)

(We had to change it because otherwise Debian users were not able to run it with proper sandbox)
Iron-Updates via Twitter: http://twitter.com/srware

Donations via Paypal and Bitcoin:
http://iron-start.com/spenden.php


Mike_Walsh
Posts: 10
Joined: Tue Nov 29, 2016 12:57 pm

Re: New Iron-Version: 54.0.2850.0 Stable for Linux

Postby Mike_Walsh » Mon Dec 05, 2016 1:16 am

Hiya, Steve.

I run Iron myself, in Puppy Linux. I re-package Iron for the 64-bit Pups, and an acquaintance does the same for the 32-bitzers.

I think you'll find that in the current release there is no 'iron' file; the binary is the 'chrome' one instead.

Code: Select all

/usr/share/iron/chrome


8th line up from the bottom of your list of files. At least, that's what's there in my downloads.....and I'm posting from the 64-bit right now.


Mike. ;)



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: No registered users and 10 guests