Some extension not running

Discussion about SRWare Iron and Google Chrome Extensions/Plugins

Some extension not running

Postby beppe » Sat Sep 08, 2012 9:21 pm

Hello everybody,
I installed some extensions dowloaded from http://www.chrome-plugins.info/en, but even they are "Active" seem that they do not work (see Extensions.jpg).
Someone can tell me the reason ?
Beppe
You do not have the required permissions to view the files attached to this post.
beppe
 
Posts: 1
Joined: Sat Sep 08, 2012 9:00 pm


Re: Some extension not running

Postby Oaken » Thu Sep 19, 2013 6:43 am

I experienced the same problems (quite a few versions back now) and am stuck with a much older version of Iron. And while I understand this is not ideal from a security standpoint, I rely upon other mitigations rather than to do without certain functionality.
That said every few weeks I'm back reading these forums to see if this has changed (back again), though this is is beginning to wear thin now.

I appreciate the lack of any unique ID, the removal of Google updater, and the other advantages of choosing Iron over it's competitors. However I feel I'm being treated as a child in that I cannot install the extensions of my own choosing.

So...

Dear developers,

Please enable us to make our own choices in this regard, and restore the ability to install extensions from the Chrome Store. Or at least get rid of the horrid start page, as well as making new tabs open at the left!

I've been an Iron user for a long time now, though this will likely change if nothing shifts in this regard, in the near future.

If I've missed something please point to it, thanks?

Many thanks,
Best Wishes,

Oaken
Oaken
 
Posts: 15
Joined: Tue Feb 22, 2011 3:51 am
Location: UK


Re: Some extension not running

Postby mapx » Thu Sep 19, 2013 10:57 pm

what's your problem ?
I can install any extension

probably your profile is damaged

try create a new profile
https://support.google.com/chrome/answer/142059?hl=en

for iron replace
\Google\Chrome\User Data\

by
\Chromium\User Data\
mapx
 
Posts: 641
Joined: Fri Jul 30, 2010 2:02 pm


Re: Some extension not running

Postby Oaken » Fri Sep 20, 2013 3:02 pm

mapx wrote:what's your problem ?
I can install any extension

probably your profile is damaged

try create a new profile
https://support.google.com/chrome/answer/142059?hl=en

for iron replace
\Google\Chrome\User Data\

by
\Chromium\User Data\


Thanks for the quick reply Mapx.
And you are likely at least partially correct...

Going back to around v21/22 I updated Iron to find 2 of my preferred extensions were no longer working. Upon troubleshooting the issue at the time I read (cannot recall 100% tho think it was on this site) that Iron would no longer support Chrome Store Extensions, as the developers considered these contrary to the improved privacy that Iron offers? Subsequently, upon the next two update attempts the situation remained the same. And between then and now I've not heard/read anything to the contrary?
Caveat: This is to the best of my recollections unless I completely misunderstood, and in which case my apologies to all concerned?

In the interim my default profile was rendered corrupt, I've no idea why, and so I created a new one. Following which I could still not get the extensions concerned installed and working.

Cutting a very long story short...
After coming back here yesterday in search of a solution, I bit the bullet and did a clean install of Iron version 29.0.1600.1. This involved removing all Iron/*Chromium related leftovers from AppData, and manually from the windows registry.

Et voila!
All is now installed and working to my satisfaction- even though I cannot say exactly how or why...

:? 8-) :shock: :geek: :D
Oaken
 
Posts: 15
Joined: Tue Feb 22, 2011 3:51 am
Location: UK


Re: Some extension not running

Postby mapx » Fri Sep 20, 2013 3:18 pm

yeah, again something messed up in your profile / registry

however, the extensions from the store are all installable in iron
the others (dev builds, from other sites) are installable going in chrome://extensions and drag & drop there the downloaded crx file
mapx
 
Posts: 641
Joined: Fri Jul 30, 2010 2:02 pm


Re: Some extension not running

Postby sara736 » Wed Oct 29, 2014 1:40 pm

I have uninstalled Iron--re-installed iron, only kept the default skin. It STILL steals the focus totally, either in full screen or semi-minimised mode--is this just my computer, or has anyone else got this annoyance??
sara736
 
Posts: 1
Joined: Wed Oct 29, 2014 1:37 pm



Return to Iron/Chrome Extensions (English)

Who is online

Users browsing this forum: No registered users and 2 guests