New Iron-Version: 4.0.227 Beta for Linux

Iron Forum for english speaking people

Re: New Iron-Version: 4.0.227 Beta for Linux

Postby PKOV7E6R » Tue Dec 15, 2009 8:39 am

Great project! Keep up the good work. :mrgreen:

Also I would like to know if there is a source tarball from which I could build a 64bit version ?
PKOV7E6R
 
Posts: 2
Joined: Tue Dec 15, 2009 12:44 am


Re: New Iron-Version: 4.0.227 Beta for Linux

Postby MentalNotes » Wed Dec 16, 2009 2:46 am

I have the same problem as jaimemistus11. I got this result from running Iron through gdb:
Code: Select all
Starting program: /home/mentalnotes/iron-linux/iron
[Thread debugging using libthread_db enabled]
[New Thread 0x7591b70 (LWP 6548)]
[New Thread 0x1a2bb70 (LWP 6549)]
[New Thread 0x222cb70 (LWP 6550)]
[New Thread 0x3977b70 (LWP 6551)]

Program received signal SIGILL, Illegal instruction.
0x084fad8a in FieldTrial::FieldTrial(std::string const&, int) ()
Current language:  auto
The current source language is "auto; currently asm".


Hope this helps.
MentalNotes
 
Posts: 1
Joined: Tue Dec 15, 2009 4:51 am


Re: New Iron-Version: 4.0.227 Beta for Linux

Postby kuwanger » Thu Dec 17, 2009 9:18 am

The illegal instruction problem probably has to do with the SRWare build being compiled for pentium4. This results in the use of sse2 instructions. Further, it sounds like the layout tests, which normal builds don't need, require sse2. So, it should be as simple as altering src/build/common.gypi to use something like an i386 arch and removing the "-msse2" and "-mfpmath=sse" to have SRWare work on most any x86 processor.

Issue 9007: Crash on illegal instruction (dependence on SSE2 for layout tests)
kuwanger
 
Posts: 1
Joined: Thu Dec 17, 2009 9:07 am


Previous

Return to SRWare Iron Support (English)

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 12 guests