New Iron-Version: 35.0.1900.0 Stable for Linux

Iron Forum for english speaking people

Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby pacman401 » Wed Jul 09, 2014 10:11 am

formoza wrote:I have a solution to the problem on flashplayer version 35:
LANG=pl /usr/share/iron/iron --ppapi-flash-path=/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=14.0.0.125
;)


yeah partial :D
that way iron starts and we can see peppr flashplayer in chrome:\\plugins
but...
still pepper flash crashes when on site try to load any flash content :|
pacman401
 
Posts: 7
Joined: Thu Oct 11, 2012 6:48 am


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby pacman401 » Wed Jul 09, 2014 11:19 am

formoza wrote:I have a solution to the problem on flashplayer version 35:
LANG=pl /usr/share/iron/iron --ppapi-flash-path=/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=14.0.0.125
;)

yeah that solution solved problem witch pepper flash usage by iron , so now we can see it properly in chrome:\\plugins
but....
[*]pepper flash is crashing when site is trying to load any flash content
[*]even when we decide to disable flash for html5 we still have problem because all html5 videos are MUTED and I was unable to restore sound (video player controls showing sound is on but muting/unmuting or changing sound level has no effect )
[*] no H.264 support ?
pacman401
 
Posts: 7
Joined: Thu Oct 11, 2012 6:48 am


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby Azrael5 » Wed Jul 09, 2014 3:43 pm

formoza wrote:I have a solution to the problem on flashplayer version 35:

LANG=pl /path/to/iron/iron --ppapi-flash-path=/path/to/pepperflashlib/libpepflashplayer.so --ppapi-flash-version=version from file manifest.json

LANG=pl /usr/share/iron/iron --ppapi-flash-path=/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=14.0.0.125

;)



too difficult to explain this solution? what are those suggestions?
Jetway pt88bspro-ec|Pentium 4 670|OCZ Platinum DDR400 4x1GB|Sapphire HD3850 AGP|Physx Ageia|Xonar d2X|Dexxa ps/2|Logitech Z-5500|Asus VB175T|Lubuntu/Xp
Azrael5
 
Posts: 72
Joined: Tue Feb 21, 2012 10:24 am


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby Azrael5 » Wed Jul 09, 2014 4:33 pm

Azrael5 wrote:
formoza wrote:I have a solution to the problem on flashplayer version 35:

LANG=pl /path/to/iron/iron --ppapi-flash-path=/path/to/pepperflashlib/libpepflashplayer.so --ppapi-flash-version=version from file manifest.json

LANG=pl /usr/share/iron/iron --ppapi-flash-path=/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=14.0.0.125

;)



too difficult to explain this solution? what are those suggestions?



it works, many thanks. Added the string to the desktop shortcut.
Jetway pt88bspro-ec|Pentium 4 670|OCZ Platinum DDR400 4x1GB|Sapphire HD3850 AGP|Physx Ageia|Xonar d2X|Dexxa ps/2|Logitech Z-5500|Asus VB175T|Lubuntu/Xp
Azrael5
 
Posts: 72
Joined: Tue Feb 21, 2012 10:24 am


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby Azrael5 » Fri Jul 11, 2014 4:59 pm

works great :mrgreen:
Jetway pt88bspro-ec|Pentium 4 670|OCZ Platinum DDR400 4x1GB|Sapphire HD3850 AGP|Physx Ageia|Xonar d2X|Dexxa ps/2|Logitech Z-5500|Asus VB175T|Lubuntu/Xp
Azrael5
 
Posts: 72
Joined: Tue Feb 21, 2012 10:24 am


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby j-mart77 » Sat Jul 12, 2014 1:20 pm

faucon50 wrote:Hi,

I upgraded to v. 35 but can't launch Iron, the error is :

/usr/share/iron/iron: error while loading shared libraries: libharfbuzz.so.0: cannot open shared object file: No such file or directory

Back to v. 34. What is the reason ?

Xubuntu 12.04 LTS
AMD HD 7750 proprietery driver


I'm also getting this error on Ubuntu 32bit. How do I roll back to version 34 though? I've uninstalled 35, but when I download the deb file from the 34 version release post and install it I still get the same libharfbuzz.so.0 error. 34 was working fine for me. Please help me get back to that version. Thanks!

I've also tried extracting the tar.gz and then running make in the extracted folder in terminal, but that gives me a message saying "No targets specified and no makefile found. Stop."
j-mart77
 
Posts: 1
Joined: Sat Jun 14, 2014 8:22 pm


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby esmenhamaire » Sat Jul 12, 2014 6:25 pm

Hello! I have not yet tried the fix mentioned above (will do so directly after I post this), but I thought I'd mention that I've noticed an oddity. I use Linux Mint, currently using LinuxMint 16 (petra) and 3.11.0-12-generic. I use Xfce for my desktop UI. I have Chromium and Firefox installed. I had a previous version of Iron installed, but when I tried to update it to the latest version, I found that the launcher claimed I was trying to run the old version of Iron against the new version's settings. So I used Synaptic to do a complete removal of Iron, then I re-installed Iron using GDebi.

Iron now works fine, but aside from the flash-playing problem that other have noticed, there's another peculiarity. I have both Chromium and Iron available on my small launcher at the foot of the desktop. If I launch Chromium, all works as one would expect, and I can watch news videos on the BBC website fine. However, if I then use the Iron launcher, I actually get another instance of Chromium - and again, flash videos are playing fine.

If, however, I close all browsers and launch Iron, I get the Iron browser, and flash videos do NOT work. If I then select the Chromium browser, I get Iron again! And this is despite their being called from different places. I presume it's to do with both browsers being based on the same sourcecode.

Can someone tell me if it's a good idea or not to have both Chromium and Iron installed at the same time? Unfortunately, I'm not terribly knowledgable on the technical side of things - perhaps slightly more so than the average computer user, but only just.

Anyway, as this is my first post here, I'd like to thank the SRWare team for their excellent efforts, and I look forward to the flashplayer problem being sorted out in Iron!
esmenhamaire
 
Posts: 2
Joined: Sat Jul 12, 2014 6:02 pm


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby esmenhamaire » Sat Jul 12, 2014 6:36 pm

As per my previous post, I tried to see whether adding the info given above about PepperFlash would work, but there's no such library in my system (I suspect maybe because I haven't had Chrome installed on my system, but have Chromium instead), so - no, that doesn't work for me. I can, however, just decide whether to start with Iron or Chromium until there is a fix in Iron :-)
esmenhamaire
 
Posts: 2
Joined: Sat Jul 12, 2014 6:02 pm


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby mazor » Fri Jul 18, 2014 6:27 am

This version still does not work on Ubuntu 12.04 LTS 32bit. Is there any fixes for this?
mazor
 
Posts: 5
Joined: Thu Jun 27, 2013 10:11 pm


Re: New Iron-Version: 35.0.1900.0 Stable for Linux

Postby rdh61 » Sat Jul 19, 2014 7:38 am

Please could you or Azrael5 explain this? Step by step, exactly what do I have to do?

Thanks.

formoza wrote:I have a solution to the problem on flashplayer version 35:

LANG=pl /path/to/iron/iron --ppapi-flash-path=/path/to/pepperflashlib/libpepflashplayer.so --ppapi-flash-version=version from file manifest.json

LANG=pl /usr/share/iron/iron --ppapi-flash-path=/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=14.0.0.125

;)
rdh61
 
Posts: 1
Joined: Thu Jul 17, 2014 10:53 am


PreviousNext

Return to SRWare Iron Support (English)

Who is online

Users browsing this forum: Google [Bot] and 15 guests