Iron won't start on Ubuntu 13.04

Iron Forum for english speaking people
Stray
Posts: 1
Joined: Sat Apr 27, 2013 7:39 pm

Iron won't start on Ubuntu 13.04

Postby Stray » Sat Apr 27, 2013 7:44 pm

Hey All,

I just upgraded my Ubuntu 12.04 to 13.04 and now Iron won't start up. Is it going to have to be upgraded for 13.04?

Thanks,
Mark


useftf
Posts: 2
Joined: Sat Mar 10, 2012 10:29 pm

Re: Iron won't start on Ubuntu 13.04

Postby useftf » Sun Apr 28, 2013 4:54 pm

Same here. The Iron 25 (64-bit) won't start up on my Ubuntu 13.04. It worked perfectly on 12.10.
Hope they're working on the new release for linux.


wakizashi
Posts: 3
Joined: Sun Apr 28, 2013 5:05 pm

Re: Iron won't start on Ubuntu 13.04

Postby wakizashi » Sun Apr 28, 2013 6:09 pm

Same on Debian Wheezy with current updates.
- Cut -
$ /usr/share/iron/iron
/usr/share/iron/iron: symbol lookup error: /usr/share/iron/iron: undefined symbol: FT_Get_Advances
- Cut -


xdron
Posts: 2
Joined: Sun Apr 28, 2013 7:13 pm

Re: Iron won't start on Ubuntu 13.04

Postby xdron » Sun Apr 28, 2013 7:30 pm

For Ubuntu 13.04 32 bit
1. Download libudev0 lib:

Code: Select all

wget -c www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_i386.deb

2. Install the library:

Code: Select all

sudo dpkg -i libudev0*.deb

3. Download Iron, install:

Code: Select all

wget http://www.srware.net/downloads/iron.deb
sudo dpkg -i iron.deb


For Ubuntu 13.04 64 bit
1. Download libudev0 lib:

Code: Select all

wget -c www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_amd64.deb

2. Install the library:

Code: Select all

sudo dpkg -i libudev0*.deb

3. Download Iron, install:

Code: Select all

http://www.srware.net/downloads/iron64.deb
sudo dpkg -i iron64.deb


seicaso
Posts: 1
Joined: Thu May 09, 2013 9:16 am

Re: Iron won't start on Ubuntu 13.04

Postby seicaso » Thu May 09, 2013 9:18 am

Hi,
I've got the same problem. It would be nice if you could make SRWare Iron work under Ubuntu 13.04!

Thanks,
Julia


Ironie
Posts: 1
Joined: Fri May 10, 2013 6:32 pm

Re: Iron won't start on Ubuntu 13.04

Postby Ironie » Fri May 10, 2013 6:47 pm

I had the same problem. Now I have a solution.

After starting ./iron in /usr/share/iron the message given was that libXss.so.1 was missing. I found the file via apt-file in the package libxss1.

So, just install libxss1.

For the lazy people:
1. Open up a terminal.
2. Get your apt-get up to date via

Code: Select all

sudo apt get update

3. Enter

Code: Select all

sudo apt-get install libxss1

and press Enter.

If Iron still does not start you also need to install udev0 like xdron posted:

Code: Select all

wget -c www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_i386.deb
sudo dpkg -i libudev0*.deb


Now you can either use iron if you already installed it or install iron from srware:

Code: Select all

wget http://www.srware.net/downloads/iron.deb
sudo dpkg -i iron.deb


Cheers.


jfrelin
Posts: 1
Joined: Wed Jul 17, 2013 11:23 pm

Re: Iron won't start on Ubuntu 13.04

Postby jfrelin » Wed Jul 17, 2013 11:27 pm

I just tried the approaches and and although the installation appears to work and the icon is created theprogram will not start. Ubuntu 13.04



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: Google Feedfetcher and 6 guests