Random "error: -105 (ERR_NAME_NOT_RESOLVED)" entries

Iron Forum for english speaking people
Concerned
Posts: 1
Joined: Wed Mar 20, 2013 12:16 am

Random "error: -105 (ERR_NAME_NOT_RESOLVED)" entries

Postby Concerned » Wed Mar 20, 2013 12:33 am

Every time I open the Iron Browser I get these randomly generated hostname requests under the "chrome://net-internals/#dns " tab. For example:

Hostname Family Addresses Expires
bwlplnkenn IPV4 error: -105 (ERR_NAME_NOT_RESOLVED) 2013-03-19 23:59:06.802 [Expired]

Hlhoiochum IPV4 error: -105 (ERR_NAME_NOT_RESOLVED) 2013-03-19 23:59:06.881 [Expired]

Jfzyuggjhc IPV4 error: -105 (ERR_NAME_NOT_RESOLVED) 2013-03-19 23:59:06.799 [Expired]

These requests for non-existent hostnames are produced by the browser only on startup.They always appear in sets of 3 and similarly appear in Google Chrome. Does anyone know what this implies?

Thanks


bksening
Posts: 59
Joined: Mon Aug 31, 2009 11:08 pm

Re: Random "error: -105 (ERR_NAME_NOT_RESOLVED)" entries

Postby bksening » Mon Mar 25, 2013 12:21 am

From Nico Weber (Chromium developer):
http://groups.google.com/a/chromium.org ... 58e6015fc5

If you type in a single-word search query, chrome needs to send a DNS request to check if this might be a single-word host name: For example, "test" might be a search for "test" or a navigation to "http://test". If the query ends up being a host, chrome shows an infobar that asks "did you mean to go to 'test' instead". For perf reasons, the dns query needs to be asynchronous.

Now some ISPs started showing ads for non-existent domain names ( http://en.wikipedia.org/wiki/DNS_hijacking ), meaning chrome would always show that infobar for every single-word query. Since this is annoying, chrome now sends three random DNS requests at startup, and if they all resolve (to the same IP, I think), it now knows not to show the "did you mean" infobar for single-word queries that resolve to that IP.


kinjo
Posts: 2
Joined: Tue Jun 21, 2016 2:33 pm

Re: Random "error: -105 (ERR_NAME_NOT_RESOLVED)" entries

Postby kinjo » Tue Jun 21, 2016 2:34 pm

did you found the fix?


kinjo
Posts: 2
Joined: Tue Jun 21, 2016 2:33 pm

Re: Random "error: -105 (ERR_NAME_NOT_RESOLVED)" entries

Postby kinjo » Wed Jun 22, 2016 12:44 pm

kinjo wrote:did you found the fix?

got the fix
http://www.deskdecode.com/err_name_not_resolved/



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: No registered users and 26 guests