error page

Iron Forum for english speaking people

error page

Postby frz » Sat Aug 22, 2009 4:45 pm

Hi,

Just a small issue.

The error pages that are displayed when Iron can't connect to a server look a bit broken, it seems like half the text is missing .

Image


Thanks.

ps. By the way I'm using Windows xp in Spanish.
frz
 
Posts: 3
Joined: Sat Aug 22, 2009 4:24 pm


Re: error page

Postby DaveIron » Fri Sep 04, 2009 2:37 am

Yes, I have seen this as well. It seems to happen in some hyperlinks on bulletin boards. It's probably a minor bug. I have found that if you 'go back' a page & try the link again it will usually work OK. It may be more prevalent on slow servers.
DaveIron
 
Posts: 119
Joined: Wed Jul 15, 2009 7:09 am


[BUG] Using hash in URL

Postby peabody » Sun Feb 28, 2010 7:28 pm

I'm having the same problem. You can generate this error at will by adding a hash mark and text into a URL.

http://domain.com/webpage.html works fine

http://domain.com/webpage.html#anchor will cause this error.
You do not have the required permissions to view the files attached to this post.
peabody
 
Posts: 1
Joined: Sun Feb 28, 2010 5:53 pm


Re: error page

Postby negated » Sun Mar 07, 2010 9:41 pm

I've noticed this same behavior (where a '#' character in a URL causes the page not to display). It has only happened since I used the new 5.x series alpha; all my previous 4.280 (and 4.275 for Linux) installs are working great.

Can people with the '#' bug please list what version of Iron they are using, what platform, and any extensions they are using?

For the record, I have IETab, Google Mail Checker Plus, and XMarks on all my Windows based systems (Win7 x64 and x32), and just the latter two on my Linux based systems (Ubuntu 9.04 x64, 9.10 x32).

Again, this is only happening on my Win7 x64 system with Iron 5.x Alpha.

Thanks,
S
negated
 
Posts: 28
Joined: Sun Mar 07, 2010 9:31 pm


Re: error page

Postby bulek » Mon Mar 08, 2010 12:36 pm

I wrote about this in Iron 5 alpha topic. I think it is not related to the Iron version. The recent adblock.ini contains a line with just "#" in it. It should be just an empty comment but Iron seems to use it for filtering. For this reason any URL with local anchor would be blocked. I have removed the "#" line ans the problem went away.
bulek
 
Posts: 91
Joined: Wed Jan 27, 2010 7:45 pm


Re: error page

Postby negated » Mon Mar 08, 2010 4:43 pm

bulek wrote:I wrote about this in Iron 5 alpha topic. I think it is not related to the Iron version. The recent adblock.ini contains a line with just "#" in it. It should be just an empty comment but Iron seems to use it for filtering. For this reason any URL with local anchor would be blocked. I have removed the "#" line ans the problem went away.


Thank you! You are right; it was just the single '#' by itself on the line after the header.

All seems to be well; thanks for replying!

-S
negated
 
Posts: 28
Joined: Sun Mar 07, 2010 9:31 pm


Re: error page

Postby Scorpius » Tue Mar 09, 2010 12:16 am

I think that means adblock.ini doesn't really support comment lines that start with #, those lines with # that we think are comments are also being interpreted as regular expression patterns for blocking :(

Anyway is you still try to go to a website that does not exist the weird page appears. Try http://www.asdlfjaldkf.com or whatever.
Scorpius
 
Posts: 3
Joined: Mon Mar 08, 2010 4:31 am


Re: error page

Postby arthurui » Sat Mar 20, 2010 3:27 pm

I had the same problem and I could repair it in the following way:
-go to Internet Options
-Connections
-Network configuration
-No proxy connection

and everything magically went ok!!
arthurui
 
Posts: 1
Joined: Sat Mar 20, 2010 3:21 pm


Re: error page

Postby Udy » Sun Mar 21, 2010 1:32 am

This is displayed when Iron can't load something. That is,
1. If a site is blocked by adblock.ini
2. If a site is blocked by hosts file (almost the same thing as adblock.ini)
3. If you are connection to the World Wide Web just died.
Udy
 
Posts: 30
Joined: Fri Feb 12, 2010 7:36 pm



Return to SRWare Iron Support (English)

Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher and 14 guests