New version of iron keeps on crashing

Iron Forum for english speaking people

Re: New version of iron keeps on crashing

Postby mapx » Fri Aug 17, 2012 7:52 am

did you look in the iron task manager to see which process is consuming a lot of resources ? (cpu, memory)
mapx
 
Posts: 640
Joined: Fri Jul 30, 2010 2:02 pm


Re: New version of iron keeps on crashing

Postby formidible » Tue Sep 25, 2012 8:22 pm

It crashes for me too but only rarely. However when I try to open an email link it gives a notice "Iron is unresposive. Re-start Iron?" When I click "yes" Iron crashes when it tries to re-start, every time. This is happening recently. When I installed the latest version the email links worked ok, but now they don't. Also I always had to have Iron open already for links to work. If Iron was not already open again it would crash when trying to open. No exceptions.
formidible
 
Posts: 20
Joined: Wed Jul 25, 2012 1:36 am


Re: New version of iron keeps on crashing

Postby dwild » Fri Nov 23, 2012 7:38 pm

for 2 days now (today 23 11 2012(german))
iron 18 _and_ iron 23 _and not chrome 23_(!)
constantly crash on my xp(3)-system.
antivir and malwarebyte didn't show any issues.
like in all other cases, iron ran fine for years(!, at least 3)

at first i guessed, flash was the issue, since it seemed to happen primarily on pages
with integrated videos, so i deinstalled/installed it; to no avail.

from the start f.e. the discogs-pages crashed after accessing more than about 5 pages,
very strange; this still continues: just type "björk" (f.i., she's not to blame),
go to an lp, klick the cover, klick back, go to another lp, and: boom!
(all pages of the windows-task crash, with the little puzzle-logo)

presuming that the new beta version of flash was the perpetrator, i deinstalled it
and installed an older 11.5-version; dito.

so, evidently, browsing through some sites for a longer time crashes instances of iron!

and now here's the surprise: chrome (23) doesn't!

(iron installed: 3 times; iron portable installed: 3 times; chrome installed: 1 time, and it works.)

i do not see hope in stack dumps, so i didn't post one.

hope you e x p e r i e n c e d ones have had the same issue, like some here; thanks beforehand.
dwild
 
Posts: 4
Joined: Fri Nov 23, 2012 7:20 pm


Re: New version of iron keeps on crashing

Postby mapx » Sat Nov 24, 2012 9:36 am

go to chrome://flags and disable / enable all the gpu / canvas/ graphic items and test again

(or you can use for iron the same settings you see in chrome://flags for chrome)
mapx
 
Posts: 640
Joined: Fri Jul 30, 2010 2:02 pm


Re: New version of iron keeps on crashing

Postby dwild » Sat Nov 24, 2012 10:11 am

as of now, today nothing crashed so far.
thanks for help, sounds promising to me.
will come back if it appears again.
(all 'flags' have (always) been deactivated here, apart from two,
which, i'm told, is the default.)
dwild
 
Posts: 4
Joined: Fri Nov 23, 2012 7:20 pm


Re: New version of iron keeps on crashing

Postby dwild » Thu Nov 29, 2012 10:26 am

hi, everyone.

i just wanted to state that i'm still here; and so is the problem.

measures taken so far:

over-installed win xp; re-installed sp3. re-installed antivir.

search for rootkits et al. memory test. harddisk tests.

all programs running smoothly.

though had an unexpected crash from firefox _and_ chrome23 doing the above.

(both cases: "the vanishing program"); but:

iron (18+23; portable versions) still keep crashing regularely, especially when run over a longer period.
(so, fi, all downloads are lost etc)

dear mapx:
all flags are _default_ set (iron_+_chrome), setting them otherwise doesn't change behaviour at all.

so my question remains: what's with iron these days (will post when i've found the answer)
dwild
 
Posts: 4
Joined: Fri Nov 23, 2012 7:20 pm


Re: New version of iron keeps on crashing

Postby dwild » Fri Nov 30, 2012 7:24 am

i don't know, where my last -quite long- post went,
but anyway,

the problem _could_ be solved now:
('ll come back if necessary)

"startpaging" (an alternative to gugle) through the web
i found a hint (after pages and pages of false hints) saying:

did you experience a "yellow alert sign" (exclamation mark)
in your taskbar?

well I didn't, but I did later, and I read on:

if so, you might be running out of _virtual memory_.
(reminiscent of win311)

so i looked for my pagefile.sys that was still there and afterwards
into system/properties/extended/"…virtual memory…"/change/extended, and
heureka!

"no page file" was set!!!
(never did this, honest; x my heart)

but this didn't come as a surprise to me, since I fi had always trouble
-and still have- with the energy-settings of xp, which get re-set
once in a while, due to a bug in xp.

iron running better now.
dwild
 
Posts: 4
Joined: Fri Nov 23, 2012 7:20 pm


Previous

Return to SRWare Iron Support (English)

Who is online

Users browsing this forum: Azrael5, Bing [Bot], Google Adsense [Bot], Google Feedfetcher and 33 guests