New Iron-Version: 5.0.377 Beta for Linux

Iron Forum for english speaking people
User avatar
SRWare
Site Admin
Posts: 1602
Joined: Sat Jan 19, 2008 4:16 am

New Iron-Version: 5.0.377 Beta for Linux

Postby SRWare » Tue May 18, 2010 6:12 am

Iron 5.0.377 for Linux is ready for download now. You can get all the new features of the 5.0-Line like the integrated content blocker and the improved performance.

Further we added adblocking and User-Agent switching, which is already known from our windows-versions. Just use UA.ini and adblock.ini for activating this features. The files must be in the current Iron"working dir".

Downloads:
http://www.srware.net/downloads/iron-linux.tar.gz (32-Bit)
http://www.srware.net/downloads/iron-linux-64.tar.gz (64-Bit)

We will also release a "P2-version" for older CPUs soon.
Iron-Updates via Twitter: http://twitter.com/srware


noctrex
Posts: 2
Joined: Thu May 27, 2010 6:00 pm

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby noctrex » Thu May 27, 2010 6:07 pm

Using Ubuntu 9.10 x86, this version of Iron does not work.
The error is:

/opt/iron-linux/iron: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by /opt/iron-linux/iron)

ubuntu 9.10 has glibc 9.10.1

I guess this runs only on Ubuntu 10.4 ?
please make it compatible for older versions.


HansH
Posts: 1
Joined: Thu May 27, 2010 9:44 pm

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby HansH » Thu May 27, 2010 9:50 pm

noctrex wrote:Using Ubuntu 9.10 x86, this version of Iron does not work.
The error is:
/opt/iron-linux/iron: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by /opt/iron-linux/iron)
ubuntu 9.10 has glibc 9.10.1
I guess this runs only on Ubuntu 10.4 ?
please make it compatible for older versions.


Works under Ubuntu 10.04 64bit, no problems sofar.
Thanks for this release, hope it will continue...


quenenni
Posts: 1
Joined: Fri May 28, 2010 1:45 am

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby quenenni » Fri May 28, 2010 2:11 am

With a (nearly fresh) Debian Testing , this version doesn't work either.

I have the same error:

Code: Select all

./iron: /lib/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by ./iron)


Code: Select all

dpkg -l libglib2.0-*

ii  libglib2.0-0                         2.24.1-1                             The GLib library of C routines
ii  libglib2.0-cil                       2.12.9-3                             CLI binding for the GLib utility library 2.12
ii  libglib2.0-data                      2.24.1-1                             Common files for GLib library


What is strange is that a friend with also a Debian testing have it working.
I'll try to find what she did to make it work.


noctrex
Posts: 2
Joined: Thu May 27, 2010 6:00 pm

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby noctrex » Tue Jun 01, 2010 5:47 pm

I have confirmed that this version runs only on Ubuntu 10.04. On older versions the application exits with the error I posted before.


gdunc
Posts: 5
Joined: Wed Dec 17, 2008 12:47 am
Location: North Carolina, USA

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby gdunc » Mon Jun 07, 2010 4:19 pm

SRWare wrote:Iron 5.0.377 for Linux is ready for download now. You can get all the new features of the 5.0-Line like the integrated content blocker and the improved performance.

Further we added adblocking and User-Agent switching, which is already known from our windows-versions. Just use UA.ini and adblock.ini for activating this features. The files must be in the current Iron"working dir".

Downloads:
http://www.srware.net/downloads/iron-linux.tar.gz (32-Bit)
http://www.srware.net/downloads/iron-linux-64.tar.gz (64-Bit)

We will also release a "P2-version" for older CPUs soon.


Is it just me or is anyone else unable to use the built in "content blocker" - adblock.ini??

I've put adblock.ini in iron-linux, in ~./config/chromium, and in ~./config/chromium/Default. All of which have no effect.

There seems to be a similar question in the German forum - viewtopic.php?f=17&t=1499 - but, I didn't see a resolution. Anyone else have an idea???


ode
Posts: 1
Joined: Wed Jun 09, 2010 12:01 am

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby ode » Wed Jun 09, 2010 12:10 am

Thanks for the new version, this is the first version that is stable enough for me to use.

One problem I have found is that Backspace and Shift+Backspace keyboard shortcuts do not work (I'm running the 64bit version.)

Thanks again.


Ezechiel
Posts: 2
Joined: Wed Jan 06, 2010 9:49 am

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby Ezechiel » Wed Jun 23, 2010 1:00 pm

ode wrote:Thanks for the new version, this is the first version that is stable enough for me to use.

One problem I have found is that Backspace and Shift+Backspace keyboard shortcuts do not work (I'm running the 64bit version.)

Thanks again.


The backspace-action has been removed. AFAIK in Chromium 5 (but I'm not sure).
Try this extension to enable backspace for navigation:
https://chrome.google.com/extensions/detail/aeffggjddcchloadflonilaahpclmbnm?hl=en

Bye...


deVars
Posts: 12
Joined: Fri Jul 02, 2010 11:33 pm

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby deVars » Fri Jul 02, 2010 11:37 pm

Is the adblock.ini and ua.ini feature implemented here in the linux version?


DonBex
Posts: 1
Joined: Sun Jul 04, 2010 2:32 pm

Re: New Iron-Version: 5.0.377 Beta for Linux

Postby DonBex » Sun Jul 04, 2010 2:49 pm

noctrex wrote:Using Ubuntu 9.10 x86, this version of Iron does not work.
[...]
/opt/iron-linux/iron: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by /opt/iron-linux/iron)

ubuntu 9.10 has glibc 9.10.1
[...]

I am experiencing a similar problem under Sabayon Linux (which is Gentoo based, btw), namely when I try to start Iron I get the following error instead:

Code: Select all

./iron: /lib/libc.so.6: version `GLIBC_2.11' not found (required by ./iron)

Sabayon is a pretty bleeding edge distro, but currently the latest version of the glibc package I can find is 2.10.1. Maybe you should try to compile Iron with glibc 2.10.1 instead of 2.11, if possible.



Return to “SRWare Iron Support (English)”

Who is online

Users browsing this forum: Bing [Bot] and 21 guests