OFFIZIELL: "Klasse nicht registriert"-Patch Test

Fragen, Support und Anregungen zu SRWare Iron

OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby SRWare » Fri Apr 25, 2014 3:35 pm

Beta-Test (für Win8-Nutzer) bevor er ins offizielle Packet aufgenommen wird

http://www.srware.net/downloads/notreg_fix.zip

Anleitung:
1) Die Dateien laden und im aktuellen Iron 34-Verzeichnis (bei anderen Versionen geht es nicht) entpacken und die vorhandenen Dateien überschreiben
2) Beliebigen anderen Browser zum Standard-Browser machen
3) Iron als Administrator ausführen, zum Standardbrowser machen und in der Liste "Chromium" wählen

Es sollte funktionieren!
Iron-Updates via Twitter: http://twitter.com/srware
User avatar
SRWare
Site Admin
 
Posts: 1653
Joined: Sat Jan 19, 2008 4:16 am


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby diet59 » Sun Apr 27, 2014 8:41 am

Funktioniert bei mir unter win 8.1 SP1 x64 prof teilweise.

Die Registrierung als Standardbrowser und Verknüpfung mit htm-Dateien ist nun optisch präsent.
Der Icon-Doppelklick funktioniert und die "Klasse nicht registriert" - Meldung kommt nicht mehr.

Der Versuch, htm-Dateien oder Links direkt zu öffnen bleibt weiterhin ohne Wirkung.
diet59
 
Posts: 23
Joined: Wed Feb 23, 2011 8:12 pm


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby SRWare » Sun Apr 27, 2014 2:57 pm

diet59 wrote:Der Versuch, htm-Dateien oder Links direkt zu öffnen bleibt weiterhin ohne Wirkung.


Danke für das Feedback. Was meinst du mit "direkt öffnen"? Der Browser startet also nicht, wenn du eine htm-Datei anklickst?
Iron-Updates via Twitter: http://twitter.com/srware
User avatar
SRWare
Site Admin
 
Posts: 1653
Joined: Sat Jan 19, 2008 4:16 am


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby diet59 » Mon Apr 28, 2014 4:07 pm

Genau, ebenso beim Klick auf einen Link in Thunderbird.
diet59
 
Posts: 23
Joined: Wed Feb 23, 2011 8:12 pm


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby neokz » Thu May 15, 2014 10:40 pm

geht mir genauso wie diet59.

Es kommt jetzt zwar keine Fehlermeldung mehr mit "Klasse nicht registriert", aber wenn ich einen Link in z.B. einer Mail in Outlook anklicke passiert nichts. Keine FM, es geht aber auch kein Fenster auf.
Wenn ich den Iron Shortcut in der Taskleiste mit der linken Mousetaste anklicke, öffnet sich ebenfalls kein Fenster.
Es geht nach wie vor nur mit der rechten Mousetaste und dann "Neues Fenster" anklicken.
neokz
 
Posts: 10
Joined: Fri Dec 12, 2008 12:15 pm


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby scratch » Mon May 19, 2014 3:51 pm

Wenn ich in einem frisch aufgesetzten Windows 8.1 die beschriebene Prozedur durchführe, funktioniert das soweit gut.
Nur versucht Iron bei jedem Start die URL
--profile-directory%3Ddefault
zu öffnen.
Das lässt sich auch nicht durch die Einstellungen 'Beim Start' beheben.

Gruß

scratch
scratch
 
Posts: 1
Joined: Mon May 19, 2014 3:45 pm


Re: OFFIZIELL: "Klasse nicht registriert"-Patch Test

Postby petertausd » Mon May 26, 2014 9:13 am

Ich habe seit V34 das Problem, dass in Windows (Win 7) Iron keine html-Dateien mehr öffnet, obwohl iron für .html(l) Erweiterungen und für http(s) Protokolle registriert ist. Ist dies das Problem mit "Klasse nicht registriert"? Wie kann ich das prüfen?

Wenn ich html-Dateien versuche zu öffnen oder auf irgendwelche URLs klicke, zB im Thunderbird, dann passiert gar nichts ...

Freue mich über jede Hilfe, auch Tipps zum Debugging ...
petertausd
 
Posts: 1
Joined: Mon May 26, 2014 9:08 am



Return to SRWare Iron Support (Deutsch)

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot], Yahoo [Bot] and 7 guests